Unterschiede

Hier werden die Unterschiede zwischen zwei Versionen angezeigt.

Link zu dieser Vergleichsansicht

Beide Seiten der vorigen Revision Vorhergehende Überarbeitung
Nächste Überarbeitung
Vorhergehende Überarbeitung
ot_diaspora_tips [2016/11/24 11:16]
johannes Schreibtest, Zugang zur TC8.VP beschrieben
ot_diaspora_tips [2019/01/13 17:59] (aktuell)
Zeile 1: Zeile 1:
 +{{:​under_construction.jpg|}}
 +
 +====== VP für das TC 11 ======
 +[[OT_TC 11.vp|Zur Hauptseite]]
 +
 +====== Tips & Tricks ======
 +
 +**__todo:​__**
 +  - Vorlage für -shp.tbm Datei erstellen und verfügbar machen
 +
 +**__Änderungen:​__**
 +  * Seite erstellt - Johannes 29.11.2014
 +
 +===== Tools =====
 +Blender: ​
 +zum bearbeiten / erstellen falls die Datei nicht direkt im DAE/Collada Format ist
 +www.blender.org
 +
 +POF Constructor Suite 2.1 (Alpha 13.July) ​
 +zum Bearbeiten / erstellen der *.POF Dateien die Diaspoa versteht
 +http://​www.hard-light.net/​wiki/​index.php/​POF_Constructor_Suite_2 \\
 +(der 3. Link verweist aufs Forum, da im 1. Posting ist der eigentliche Link)
 +
 +Mein Weg beim anpassen von z.B. *.3ds Vorlagen an [[ot_diaspora|DIASPORA]]:​
 +//(Andere Format sollten eigentlich genauso gehen)//
 +
 +===== Blender: =====
 +
 +  - Archiv mit dem Mesh entpacken, am besten *.3ds und Texturen alle in einen Ordner kopieren ​
 +  - Ctrl-N für NEW, dann Kamera, Licht & den CUBE löschen (R-Klick, X)
 +  - Den Mesh importieren (File|Import|3D Studio)
 +     * :!: Size Constraint: von 10 auf 1000 ändern FIXME Ist der Faktor immer richtig???
 +  - Modus auf "​Texturierte Darstellung"​ ändern (unten runder Ball auf rot-weiß stellen) um zu sehen ob die Texturierung klappt.
 +     * falls das nicht geht, *.3ds Datei im Notepad öffnen und nach dem Namen der Texture suchen. Endet meist auf .TGA
 +     * die vorhandene Texture z.B. mit IrfanView ins TGA Format ändern und abspeichern. ​
 +     * zurück nach -> 2.
 +     * FIXME Falls das immer noch nicht geht.. 8-o, keine Ahnung was dann.
 +     * FIXME Manchmal wird trotz der richtigen Darstellung in Blender die Textur(-infos) nicht mit exportiert... :?:
 +  - Rechts oben im "​Scenen-Baum"​ sollte nur ein Hauptobjekt zu sehen sein. Das Umbenennen in "​detail0"​
 +     * theoretisch könnte man jetzt auch noch diverse PATH's und Dockingpunkte einfügen...
 +     * Ebenfalls könnte man nun Meshes mit weniger Poly's für die Darstellung aus weiterer Entfernung erstellen und hier als "​detail1"​ etc einbauen
 +  - Optional: Mesh als .blender speichern
 +  - Mesh exportieren (File|Export|Collada (.dae))
 +     * Texture Options: Include UV Textures, Include Material Textures, Copy gesetzt :?: Ist das nötig
 +     * Collada Options: Triangulate,​ Use Object Instance gesetzt :?: Ist das nötig
 +
 +===== POFCS2: =====
 +
 +  - *.DAE Datei laden, Modell mit Texturen sollte nun zu sehen sein.
 +  - in der rechten Spalte unten Größe des Modells kontrollieren (H: xx.x, W: xx.x, D: xx.x) D = Länge, alles ok -> 3.
 +     * falls die Länge nicht stimmt kann dies mit dem Button [Transform] rechts oben angepasst werden
 +     * unter [Scale] (*) All axes und unten den Faktor angeben (Mathe! 8-O gewünschte Länge / aktuelle Länge = gesuchter Faktor ^_^)
 +  - Kontrolle der richtigen Orientierung:​ View -> Top Zeigt die Oberseite View -> Front die Vorderseite :!: Meistens ist Vorne <-> Hinten vertauscht
 +     * Falls das Schiff Vorne <-> Hinten vertauscht: [Transform ] -> Rotate -> (*) y-Achse & 180 Grad
 +  - [Recalculate] um den "​Moment of Inerta"​ neu zu berechnen :?: Ist das nötig
 +  - Optional: links im Baum "​Textures"​ auswählen, rechts dann unter "​texture"​ den neuen Namen eingeben und mit "​Select"​ auswählen.
 +     * Name nicht zu lang FIXME max. 15 Zeichen???
 +     * Falls unter 1. keine Texturen mit geladen wurden kann hier u.U. genauso die Texture nachgeladen werden. Nach "​Select"​ dann [Reload Textures].
 +  - Optional: Weapon Points, Thrusters etc. definieren
 +  - xxx.pof Datei speichern
 +     * xxx sollte nicht zu lang und ohne Leerzeichen sein 
 +  - xxx.pof Modell-Datei -> Diaspora\data\models kopieren
 +  - xxx.jpg Texture-Datei -> Diaspora\data\maps kopieren
 +
 +===== xxx-shp.tbm Datei erstellen: =====
 +
 +  - vorhandene (und passende) *-shp.tbm Datei mit neuem Namen kopieren
 +  - mindestens $Name:, $Short name: und $POF file: entsprechend anpassen
 +  - falls nötig $Species: anpassen
 +  - Optional: Infos anpassen
 +  - xxx-shp.tbm Table-Datei -> Diaspora\data\tables kopieren
 +
 +----
 +
 +.
 +
 +FIXME  (geschrieben von: Johannes 3.11.2015)
 +
 +**ACHTUNG!** ​
 +Die so erstellten Tabellen Und Schiffe funktionieren augenscheinlich im Moment nur im __Single__-Player sicher.
 +Für ein sicheres Multiplayerspiel müssen sowohl die Schiffe alle "​erforderlichen"​ Punkte und Systeme als auch dazu passende Tabellen haben.
 +
 +Stand der Planung nach TC8 ist:
 +Es wird __eine__ Anlaufstelle geben für die Modelle, Tabellen etc. Dort findet man dann die überprüften Modelle. Aus diesen werden dann die entsprechenden Missionen für die TC's gebaut.
 +Es ist geplant das Ashkain dazu einen Server aufsetzt, auf den wir lesend zugreifen können um uns die entsprechenden Modelle zu holen. ​
 +Er überprüft die ihm zugesandten Modelle und stellt sie Online, sofern diese in Ordnung sind.
 +
 +Der aktuelle Stand ist eine TC8.vp die über Ashkain'​s Homepage heruntergeladen werden kann. Daten dazu sind im Forum
 +
 +FIXME 
 +===== FRED: =====
 +
 +  - In FRED sollte nun die Datei in der Schiffsliste auftauchen
 +  - Test-Mission erstellen mit Rundkurs und das neue Modell diesem folgen lassen
 +  - mit ein paar "​original"​ Schiffen die Größe überprüfen
 +  - in Diaspora das Schiff begutachten
 +
  
 
 ot_diaspora_tips.txt · Zuletzt geändert: 2019/01/13 17:59 (Externe Bearbeitung)
[unknown button type]
 
Recent changes RSS feed Driven by DokuWiki